Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

The Workspace is the main control center for managing files in 010 Editor and includes three tabs: Workspace, Project and Explorer. Use the Workspace tab to manage open, favorite, recent and bookmarked files and use the Explorer tab to browse for files on disk. Projects can be managed using the Workspace tab or the Project tab. Show or hide the Workspace tabs using the 'View > Workspace Windows' menu. The list of currently open files can be saved to disk as a Workspace file. The following sections describe the different tabs of the Workspace.


Workspace

The Workspace tab is used to open files or manage files in the editor. Six sections of files are displayed with a folder icon besides each heading. Double-click the folder title to expand or hide the section of files (the folder icon will change from opened to closed or vice-versa). The files are displayed with the file name on the left side of the Workspace and the path on the right side in a lighter color. Each section is sorted by file name, but only part of the file name will be displayed if the name is too long. To see the full file name, place the mouse cursor over the name in the list. The six sections are as follows:

  • Open Files - Displays a list of all files currently open in the editor. Double-clicking on a file name will activate that file and bring the corresponding Editor Window to the front. Right clicking the file will display a menu with options for the file: 'Activate' brings the file to the front, 'Close' closes the file, 'Save' saves the file to disk, 'Add to Favorites' adds the file to the Favorites list (see below), 'Add to Project' adds the file to the current project, and 'Properties...' displays the file properties. If a project is loaded that has an associated workspace, the header for this section will display Open Files: <project_name>, otherwise it will display Open Files.

  • Project - Shows all files in the current project. The header displays Project if no project is loaded or Project: <project_name> if a project is active. Any files within the project can be opened by double-clicking and any folders in the project can be opened or closed by double-clicking. The project section is duplicated in the Project tab and see Using Projects and Workspaces for more information.

  • Favorite Files - Displays a list of favorite files for easy access. Files can be added to the list by right-clicking on a file in the Open Files, Recent Files, or Bookmarked Files lists and clicking the 'Add to Favorites' menu option. As well, files can be added to the Favorites list by dragging and dropping within any of the sections of the Workspace. Remove files from the list by right-clicking on a file in the Favorites list and selecting the 'Remove from Favorites' menu item. Select 'Open' from the right-click menu or double-click the file name to open the file. By default each favorite file has a star displayed beside the file name and to disable the display of the star, right-click on the workspace, select Workspace Options and uncheck Show Favorite Icons.

  • Recent Files - Displays a list of all files which have been edited recently, but are not currently open. Double-click the file name or click 'Open' from the right-click menu to open the file in the editor. Right-clicking the file and selecting 'Add to Favorites' will add the file to the Favorites list (see above). The list of recent files can be sorted either by the order that they were accessed or sorted by file name. To sort the list in access order, right-click the Recent Files and click 'Sort Recent Files > By Time' or to sort by file name choose 'Sort Recent Files > By Name'. A file can be deleted from the Recent Files list by right-clicking on the file and selecting the Remove from Recent Files menu option, and all files can be removed from the list by right-clicking on a file and selecting Clear Recent Files List. The number of items in the Recent Files list can be configured in the General Options dialog.

  • Recent Projects - Shows a list of recently opened or saved project and workspace files. Double-clicking on a item loads that project or workspace file. See Using Projects and Workspaces for more information. The list can be sorted by right-clicking on the list and choosing Sort Recent Projects or by using the Workspace Options dialog. Sorting options include By Time, meaning the list is sorted with the most recently accessed at the top, or By Name meaning the list is sorted alphabetically.

  • Bookmarked Files - Displays a list of all files that contain bookmarks (see Using Bookmarks for more information). Bookmarks are saved and loaded automatically when the program exits and restarts. Double-click the file, or select 'Open' from the right-click menu to open the file in 010 Editor. From the right-click menu, select 'Add to Favorites' to add the file to the Favorites list (see above), or click 'Clear Bookmarks' to remove all bookmarks from the file.

The different sections of the Workspace can be hidden by right-clicking on the Workspace and selecting 'Workspace Options' to access the Workspace Options dialog. By default, any modified files in the Open Files list are displayed with bold text and include a * after the file name. To display the files in regular typeface instead of bold, uncheck the Show Modified as Bold toggle in the Workspace Options. Additionally, bold can be removed from the headers of the six different sections by unchecking Show Headers as Bold.

Drag-and-drop is supported between the different sections of the Workspace. For example, files may be dragged from the list of Open Files onto the list of Favorite Files to add them to the Favorites list. Drag files from any of the lists to the Open Files section or the File Tabs to open the files. Multiple files can be selected at one time using either the Shift or Ctrl key (Cmd on macOS).


Project

Use the Project tab to view the current project or a list of recently used projects. This tab is discussed in the separate Using Projects and Workspaces help topic.


Explorer

A simplifier File Explorer is integrated directly into 010 Editor. This explorer provides an easy way to locate files on a hard drive and can be accessed by clicking the Explorer tab. The Explorer is divided into 4 areas:

  • Directory Name - The drop-down list at the top of the window displays the current directory. To jump to another directory, enter the directory name in the field and press the Enter key. Click the down arrow to the right of the drop-down list to access a list of recent directories.

  • Directory Tree - A list of all drives and directories is displayed in a tree below the Directory Name. Open or close directory items by double-clicking the directory name, or single-clicking the arrow icons. Double-clicking on a file opens that file in the editor. Files can also be opened by right-clicking on a file name and selecting 'Open' from the popup menu. The Name, Size, Type, and Date Modified for each file are displayed in the list by scrolling to the right.

  • Filter - A Filter field is displayed at the bottom of the dialog. Only the files that match this filter will be displayed in the Directory Tree. Enter a new filter in the field and press the Enter key to refresh the display. A list of previous filters can be accessed by clicking on the down-arrow located to the right of the Filter field.

  • Root - The root directory for the Explorer can be specified in the Root field. When a root directory is entered the Explorer will only show the files and folders in that root directory or its subdirectories. After entering a root directory press the Enter key to refresh the list. To disable the use of a root directory and show all available directories, delete the string in the Root field or enter '(none)' and press the Enter key. The down-arrow to the right of the Root field is used to access a list of recently used root directories.

NOTE: The Workspace is a Dock Window. The tabs can be moved to other locations by clicking and dragging on the dock header bar and the individual tabs can be dragged to rearrange them or move them to their own floating window. Right-click the window and deselect the 'Allow Docking' toggle to prevent a tab from docking.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v14.0 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com