Edit Anything

Professional text and hex editing
with Binary Templates technology.






010 Editor - Text/Hex Editor Homepage

A project is list of files being worked on and the list can be organized into a tree structure with a series of folders. The files in a project can either be opened or closed in 010 Editor. A workspace file is a file containing a list of all the open files in 010 Editor including how their tabs are laid out and any extra Floating Tab windows. Projects can be created with or without an associated workspace. All files in a project are displayed in the Project node of the Workspace tab or the Project tab. Manage files in the project using the Project Menu or by right-clicking on the Project structure in the Workspace tab or Project tab. Projects are saved to disk with extension ".1pj" and workspace files are saved with extension ".1wk".


Creating Projects and Project Options

A new project can be created by clicking 'Project > New Project/Workspace' which displays the Project Options dialog:

If the Store Workspace with Project (Open Files) toggle is checked, a workspace file will be associated with the new project and all currently open files will be closed when the project is created. If the toggle is not checked then the workspace from the current application is used instead. When a project is loaded that has an associated workspace then the Workspace will show Open Files: <Project Name> but if no workspace is associated the Workspace displays just Open Files.

When the Store Paths Relative to Project File toggle is set, any paths stored on disk will be relative and if the toggle is not set the paths will be stored as absolute. For example, if the project file is "C:\Projects\Proj1.1pj" and the data file is "C:\Projects\Data\File1.dat" then the relative path is "Data\File1.dat" and the absolute path is "C:\Projects\Data\File1.dat". Use relative paths if the project file is moved with the data files.

When a project is created, the project is not saved to disk until 'Project > Save Project' or 'Project > Save Project As' is clicked. When a project is modified a '*' symbol is displayed after the project name in the Workspace tab or the Project tab. After a project is assigned a file name by saving, then adding or moving a file within the project will cause the project to be modified. If the Auto-Save Project toggle is set in the Project Options dialog then the project will automatically be written to disk. If Auto-Save Project is not enabled then the project must be saved manually using 'Project > Save Project'.


Opening and Closing Projects

Project or workspace files can be opened using the 'Project > Open Project/Workspace' or 'Project > Open Recent Projects' menu options. The Workspace tab and Project tab contain a list of recent projects and workspaces and double-clicking on an entry will load that project or workspace file. Note that only one project can be loaded at a time. When loading a workspace file the current workspace is replaced by the workspace in the file. If loading a project and the project has an associated workspace, the current files are closed and all the files in the workspace file are loaded instead. Project and workspace files can also be opened using the command line, the ProjectOpen function, by double-clicking a project in the Windows Explorer, and by dragging and dropping a project from the Windows Explorer to 010 Editor.

Close a project using 'Project > Close Project' or by hovering the mouse over the project name in the Workspace tab or Project tab and clicking the 'X' button as shown in the above figure. If the current project has an associated workspace then the currently open files are closed and the files from the default application workspace are loaded instead.

If a project is active when 010 Editor is closed, that project will automatically be reloaded when 010 Editor is restarted. See the Opening Files Options dialog and the Remember Last Project option to disable this function.


Viewing and Editing Projects

 

Projects may be viewed using the Project section of the Workspace tab (shown above left) or the Project tab (shown above right). Both areas show the same information. When a project is loaded, the project heading indicates Project: <project_name> and when no project is loaded the heading indicates just Project. If a project is loaded that has an associated workspace, the workspace will indicate Open Files: <project_name> but if no associated workspace is found just Open Files will be listed instead. To open files in a project, double-click on a file or drag one or more files to the File Tabs.

Edit projects using the Project Menu or by right-clicking on a project node in the Workspace or Project tab. To add files to the project see the Adding Files to Projects section below. After files have been added to the project they can be rearranged or moved inside folders by clicking and dragging a file in the Workspace or the Project tab. Right-click on a file in a project and select Remove from Project or press the Delete key on the keyboard to delete the file from the project. Note this does not delete the file on disk.

By default the Workspace shows the project information as a duplicate of the Project tab but the project can be hidden in the Workspace by right-clicking on the Workspace and selecting Workspace Options (see Workspace Options for more information).

Once a project has been saved to disk, the source XML for the project can be viewed by right-clicking on the Project node and selecting Edit Project. The XML data will be opened as a file in the editor.


Adding Files to Projects

To add files to the current project click 'Projects > Add to Project' or right-click on the project node in the Workspace tab or the Project tab and select Add to Project. The following options are available for adding files:

  • Existing Files - Opens a standard file dialog box that can be used to select one or more files to add to the project.

  • Existing Folder - Displays a standard folder dialog box that can be used to select a live folder on disk to add to the project. See Project Folders and Live Folders for more information.

  • New Folder - Creates a new folder in the project that is not associated with a directory on a hard disk. Files in the project can be dragged inside the folder. See Project Folders and Live Folders for more information.

  • Current File - Adds the currently active file to the project and note the current file is marked as bold in the list of tabs for the application.

  • All Open Files - All currently open files are added to the project. If any of the files are already in the project they will not be added.

Files can also be added using drag and drop within the Workspace. For example, files can be selected in the list of Open Files or Favorite Files and then dragged into the project. Multi-select is also supported with drag and drop using the Shift and Control keys (Cmd on macOS).

Project Folders and Live Folders

Two types of folders exist when working with projects:

  • Project Folder - A regular folder that can hold multiple files or other folders. The folder does not exist on disk. Any other file or folder can be dragged into this folder and all the files inside the folder do not have to exist in the same directory. Create a project folder by clicking New Folder when adding files to a project.

  • Live Folder - A folder which exists on disk and all the files inside the folder are automatically added to the project as well. A mask can be used to limit which files are included. The files in the folder are refreshed whenever the project is opened or when 'Project > Refresh Folders' is clicked. Create a live folder by clicking Existing Folder when adding files to a project.

Once a live folder is selected, the following dialog is displayed that can be used to select a Filter for the folder. Only those files that match the filter are added to the project and if no filter is specified then all files are added. Multiple filters can be specified using ',' or ';' between the filters. If the Include Subdirectories toggle is set then files in the subdirectories of the folder that match the filter are added as well. Right-click on the added Folder and select Folder Options to change the filter for the folder. Note that when adding an existing folder, the individual files are not stored with the project and the folder is rescanned for files whenever the project is opened. To force the folders to rescan click 'Project > Refresh Folders' on the main menu or right-click on the folder and select Refresh Folders. Other files or folders cannot be dragged inside a live folder and use a regular Project Folder instead to hold other files or folders.

To open or close a folder, double-click on the folder name or single-click the arrow to the left of the folder icon. The open status of a folder is saved with the project file. To rename a folder, select the folder and then single-click the name or right-click the folder and select Rename.


Searching in a Project

All files in a project can be searched simultaneously using the Find In Files bar and choosing Current Project as the search target in the in Files field.


This is the manual for 010 Editor, a professional hex editor and text editor. Use 010 Editor to edit the individual bytes of any binary file, hard drive, or process on your machine. 010 Editor contains a whole host of powerful analysis and editing tools, plus Binary Templates technology that allows any binary format to be understood.





Newsletter - Receive special offers, tips, tricks and news. Join now



010 Editor v13.0 is here!
What's new?


Navigation


Products

010 Editor














E-mail: info@sweetscape.com